Table of Contents

SOLIDWORKS Electrical .............................................................................................................. 3
  Launching ................................................................................................................................. 3
  Project Manager ....................................................................................................................... 3
  Changing the Project Language .............................................................................................. 3
  Application Tabs ....................................................................................................................... 4
Projects ...................................................................................................................................... 5
  Sample Projects ...................................................................................................................... 5
  Creating a New Project ............................................................................................................ 5
  Task Pane ................................................................................................................................ 6
  Documents Task Pane ............................................................................................................. 6
  User Documents ...................................................................................................................... 7
SOLIDWORKS Electrical Documents .......................................................................................... 7
  Data Files .................................................................................................................................. 7
  Components Task Pane .......................................................................................................... 8
  Project Tab ................................................................................................................................. 9
  Process Tab ................................................................................................................................. 9
Drawings ...................................................................................................................................... 10
  Draw Tab .................................................................................................................................. 10
  Line Diagram Tab .................................................................................................................... 11
  Schematic Tab .......................................................................................................................... 12
  Schematic Wires ...................................................................................................................... 13
Drawing Scheme Wires ................................................................................................................ 13
Inserting Symbols ........................................................................................................................ 14
  Insert Symbol Command ......................................................................................................... 15
  Symbols Palette ........................................................................................................................ 16
  Copy/Paste ................................................................................................................................ 16
  Macros Palette .......................................................................................................................... 17
SOLIDWORKS Electrical Components .................................................................................... 18
  Symbols and Components ........................................................................................................ 18
  Applying Manufacturers’ Parts Data ......................................................................................... 19
PLC Manager .............................................................................................................................. 20
Wire Numbering .......................................................................................................................... 22
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managing Terminals</td>
<td>23</td>
</tr>
<tr>
<td>Wiring Diagram Cable Reservation</td>
<td>23</td>
</tr>
<tr>
<td>Inserting Terminals</td>
<td>24</td>
</tr>
<tr>
<td>Editing Terminal Strips</td>
<td>24</td>
</tr>
<tr>
<td>Reports</td>
<td>26</td>
</tr>
<tr>
<td>Editing a Template</td>
<td>26</td>
</tr>
<tr>
<td>Generating Reports</td>
<td>27</td>
</tr>
<tr>
<td>Cabinet Layouts</td>
<td>28</td>
</tr>
<tr>
<td>2D Cabinet Layouts</td>
<td>28</td>
</tr>
<tr>
<td>3D Cabinet Layouts</td>
<td>29</td>
</tr>
<tr>
<td>Printing</td>
<td>30</td>
</tr>
</tbody>
</table>
SOLIDWORKS Electrical

Launching
SOLIDWORKS Electrical can be launched from the desktop shortcut or from the Windows Start, Programs, SOLIDWORKS-Electrical, SOLIDWORKS Electrical. Alternatively use the desktop shortcut.

Project Manager
On starting SOLIDWORKS Electrical the Project Manager will be automatically displayed. Through this interface it is possible to open existing projects, create new projects, delete projects, archive, (zip), unarchive, (unzip), create copies of projects or to change the properties of specific projects.

There are two tabs listing projects:

- **Recent projects**: Projects recently opened in SOLIDWORKS Electrical.
- **All projects**: All projects created/held within SOLIDWORKS Electrical.

Changing the Project Language
The SOLIDWORKS Electrical interface language can be changed via the “Tools->Interface configuration->Application language”. Select the preferred language from the pull down and restart the program to have the changes implemented.
Application Tabs

The number of tabs available is automatically updated by SOLIDWORKS Electrical in order to provide tools that are relevant to the work being carried out, so that on opening a Wiring Diagram a Line Diagram tab will be activated, for example.

Before opening a project there are a number of tabs that are available.

1. "File" Tab

Provides access to the Project Manager, Quit the program, archive or unarchive environments, create new drawings...

2. "Library" Tab

Provides tools to manage all the Symbol types within SOLIDWORKS Electrical in addition to manufacturers’ part data, and ERP connection.

3. "Tools" Tab

This tab includes commands to modify the application settings, chat to others connected to the same server, and set up graphic preferences.

4. "Help" Tab

The “Help” tab accesses a tutorial, supporting documentation, collects information about your system...
Projects
Projects are made up of the documents required to create an electrical project. There are a range of different drawing types available that have different intelligence within the project itself.

Sample Projects
A number of sample projects are included in the installation, and can be used in order to help familiarize new users with the content type available within SOLIDWORKS Electrical.

These projects can be accessed from the Project Manager, simply double click on a project to have it opened, or select it on the list and press the “Open” icon.

Creating a New Project
There are a number of ways to create a new project:

- Create an empty project: Create a project “from scratch.”
- Create from a template: Creates a project from a “template” this can include an entire drawing set previously defined by the user. This is a very useful tool when providing projects to different customers that each require different settings, such as numbering, drawing borders etc.
- Duplicate an existing project: Creates a copy of an existing project, which can then be modified in order to create a new project.
Task Pane

Note: The task pane can be shown or hidden from the View tab.

The task pane is displayed by default on the left hand side of the screen, here can be found listed all of the documents held within an open project, in addition to all the Components within the project drawing set.

Documents Task Pane

The document set contained within a project can be broken down as follows.

- **Project** level, this contains all documentation
- **Book**, groups documents in a set that will be printed as a set.
- **Folder**, can be used to organize document sets in a book

- **Documents** these are scheme’s, Wiring Diagrams, Terminal drawings etc.

There are a range of documents available in SOLIDWORKS Electrical, some are created by the user while others are automatically generated and maintained by the program.
### User Documents

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Cover Sheet" /></td>
<td>A cover page for the project documentation.</td>
</tr>
<tr>
<td><img src="image" alt="Wiring Diagram" /></td>
<td>A single Line Diagram representing the overall installation/machine etc.</td>
</tr>
<tr>
<td><img src="image" alt="Scheme Drawing" /></td>
<td>Electrical schematic</td>
</tr>
</tbody>
</table>

### SOLIDWORKS Electrical Documents

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Terminal Strips" /></td>
<td>These drawings are automatically generated based on the Terminals held with the project schemes</td>
</tr>
<tr>
<td><img src="image" alt="Reports" /></td>
<td>Reports created based on data applied to the project, BOM’s, Parts lists, Connection reports etc.</td>
</tr>
<tr>
<td><img src="image" alt="3D Cabinets" /></td>
<td>3D assemblies managed within SOLIDWORKS</td>
</tr>
</tbody>
</table>

### Data Files

Data files are external files that have been copied into the project, and can be in any file type format.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="DWG drawing.dwg" /></td>
<td>DWG/DXF files are managed as SOLIDWORKS Electrical documents, a preview of them is displayed and the can be modified and printed.</td>
</tr>
<tr>
<td><img src="image" alt="Any other file type" /></td>
<td>Any other file type can be added to a project, but it is not possible to preview or edit them within SOLIDWORKS Electrical. In order to edit these file types it is a requirement that a program which can open them is available on the PC.</td>
</tr>
</tbody>
</table>
**Components Task Pane**

Here can be found a list of all of the physical Components held within the project, each represents an electrical Component and is identified by a mark value, each Component can be made up of multiple Symbols. It is possible to apply multiple manufacturers’ parts to a Component. An example of a Component is a coil or relay; this is represented by a coil/relay Symbol and the various contacts within the scheme drawings, additionally it can be shown in a Wiring Diagram and in a 3D cabinet or installation. Regardless of how many different Symbols are used, or the drawing types they are in they are all regarded as a single Component.

![List of Components](image)

Depending on drawing type the Symbol is placed in a different icon will be used.

- Inserted in a Wiring Diagram
- Inserted in a Scheme Drawing
- Inserted in a 3D SOLIDWORKS Drawing
- Inserted in a 2D “Cabinet”
- Associated Connection Label

By right mouse clicking on any listed item it is possible to preview it, or go directly to it.

A Component can have several manufactures parts assigned to it, the main reference, (Base), and auxiliaries added/assigned to the base.

Terminals have a different icon and are grouped together on the Terminal strip which they are assigned to.
**Project Tab**

On opening a project the *Project* tab will appear and become active, there are a number of commands related to the management of the project.

- Manage project properties and configuration.
- Print project documents.
- Manage locations and functions.
- Manage electrical data as cables, wire type, wire links, cabling order.
- Manage PLC and Inputs / Outputs.
- Report management and creation (drawings, reports, bill of material, cabling list, etc.).

**Process Tab**

Processes can be run across all drawings in a project.

- Update/replace data project wide
- Wire numbering.
- 3D SOLIDWORKS cabinet layout.
- 2D cabinet layout
- Project translation.
Drawings

Depending on the drawing type that is open a variety of tabs will become available with commands that are directly relevant to the drawing being worked on. The information applied to **Symbols**, and wires in *Wiring Diagrams* and schemes provide the data used for the automatic generation of reports etc.

*Wiring Diagram*  
*Scheme Drawing*

**Draw Tab**

The *Draw* tab has commands includes all the tools necessary for drawing shapes, inserting text, images, dimensions, etc. These commands supply only supplementary graphical information to a scheme or *Wiring Diagram* rather than any intelligence. The commands are very useful when creating **Symbols**.
Line Diagram Tab

Opening a Wiring Diagram will activate the Line Diagram tab, the commands here allow for the creation and maintenance of Wiring Diagrams.

- Insert Symbols and draw cables.
- Insert origin/destination arrows between diagrams.
- Draw function and location outlines.
- Edit cabling between Components.
Schematic Tab

Opening a scheme drawing will activate the Schematic tab, the commands here allow for the creation and maintenance of scheme drawings.

- Draw electrical wires for power or command schemes.
- Insert Symbols, Terminals...
- Define origin/destination arrows between schemes.
- Draw function and location outlines.
- And more...
Schematic Wires

There is no limit to the number of wires available in any project, each wire style can be defined in the Line Style Manager and can a unique color, numbering system, gauge, line type...Additionally there are commands to define and draw power and/or command wires to ease design.

Drawing Scheme Wires

There are two distinct commands for drawing scheme wires:

On selecting either command the Command Panel will become active.
From here, the Line Style Manager can be accessed to select, create or modify a line style.

All line styles in the project are listed here, and are grouped by Numbering group, the numbering group indicates that all the wires in the same group will have the same counter applied to them when they are numbered.

**Inserting Symbols**

SOLIDWORKS Electrical comes with a range of electrical Symbols standards; these can be further developed to suit individual company needs.

There are a number of ways to insert Symbols into a scheme drawing:

- Insert Symbol Command
- Symbols Palette
- Copy/Paste
- Macro Palette
Insert *Symbol Command*

On selecting the command the Command panel will become active.

The *Other Symbol* button opens the *Symbols Selector* dialog where another *Symbol* can be selected.
**Symbols Palette**

On opening a Scheme Drawing two side-panel options become active *Symbols* and *Macros*.

The *Symbols Palette* is a shortcut to access the *Symbols* library.

The listed groups can be customized to provide quick access to the most commonly used *Symbols*, rather than listing every *Symbol* available.

Using the *Find* option is run across all library *Symbols*, not only those shown.

**Copy/Paste**

SOLIDWORKS Electrical uses the Microsoft Windows standards for Copy [CTRL+C], Paste [CTRL+V], Drag and Drop, Undo [CTRL+Z], Redo [CTRL+Y], etc.

Any *Symbol* can be copied in the same scheme, from one scheme to another, or from one project to another.

A *Symbol* can be copied by pressing Ctrl + Left Clicking on it and dragging the copy to the new location.

When a *Symbol* is copied, a new *Component* is created and the *Symbol* receives a new mark.
Macros Palette

*Macros* are a time saving feature, they can be single or multiple entities of any type, so that if there is a certain circuit type that is often used, a DOL for example, it can be saved as a *Macro* and then just be dragged into dropped in drawings.

To create new *Macros* simply select information in a scheme drawing and drag it into the *Macro Palette*.

It should be noted that *Macros* are drawing type specific, so that a *Scheme Macro* cannot be inserted into a *Line Diagram* and vice versa.
SOLIDWORKS Electrical Components

A Component is by definition an electrical device. It includes devices such as circuit breakers, contactors, Terminal strips and PLCs.

Each Component has a mark that identifies it. Typically a Component is represented by one or more Symbols sharing the same mark, but SOLIDWORKS Electrical also manages Components without a graphical representation in the scheme.

Symbols and Components

When a Symbol is inserted in a schematic or line diagram sheet, the Symbol editor window opens where a new mark can be defined; on applying the mark a new electrical Component is created. You can also associate a Location and a Function to a Component.

Symbols that have the same mark value applied to them are automatically associated to one another and so to the same Component, unless a Manual mark is applied.
On inserting a Symbol the Symbol Properties dialog is displayed, and the Components currently in the project are listed on the right hand side. An association is formed by selecting a listed Component, and the Symbol becomes part of the Component.

By selecting the Manual mark option it is possible to duplicate mark values but have separate Components.

**Applying Manufacturers' Parts Data**

It is possible to create components in SOLIDWORKS Electrical without having to have any inserted symbol, these components are stored in the SQL database only, and can have a manufacturers part assigned to them. This allows for feasibility studies to be carried out prior to undertaking any actual design work, as certain reports can be generated, (BOM, Parts...), based on the components that have been created.

Alternatively, parts can be applied to the symbols inserted in drawings that make up the component.

Generally manufacturer's parts are allocated when inserting symbols. The Symbol properties dialog has a tab to access and search for and define references.

Use the "Search" button. You can browse the catalog using the filters to find the reference you need.
The pin, (terminal), numbering for symbols is obtained from the manufacturers’ part. Color coding is used to easily identify if the parts data being applied to a symbol matches correctly.

- **Correct**: The values match both the symbol and manufacturers part
- **Incorrect**: The value required by the symbol is not found in the manufacturers part
- **Spare**: The value in the manufacturers part is not found in the symbol

**PLC Manager**

SOLIDWORKS Electrical allows you to manage any type of PLC. It can be a single PLC or PLC with rack and controller cards. There are two interfaces, one to manage the structure of the PLC and a second to manage IO.

PLC drawings can be automatically generated, or individual PLC’s can be inserted into *Schemes*.
To launch the PLC drawing, click on the Generate / Update drawings button.
Wire Numbering

The *Number Wires* process applies the numbering parameters defined in the *Line Style Numbering Group* to calculate the wire values.

There are options to number equipotentials or number individual wires that make up an equipotential.

In the *Line Style Manager*, wires are grouped by *Numbering Group*, this means they share the same counter. Each wire has a configurable wire numbering formula.

There are two commands to number wires, located in the *Process* tab.

- **Numbers wires that do not yet have a value applied to them.**
- **Renumber wires.**

Wire mark values can also be changed using the *Contextual Menu* (Right Click on a wire).

<table>
<thead>
<tr>
<th>Wire style</th>
<th>Wire properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equipotential properties...</td>
<td></td>
</tr>
<tr>
<td><strong>Edit wire mark...</strong></td>
<td></td>
</tr>
<tr>
<td>Align texts</td>
<td></td>
</tr>
<tr>
<td>Show / hide equipotential labels</td>
<td></td>
</tr>
<tr>
<td>Show / hide wire marks</td>
<td></td>
</tr>
<tr>
<td>Show / hide wire labels</td>
<td></td>
</tr>
</tbody>
</table>
Managing Terminals

SOLIDWORKS Electrical provides the opportunity to create a *Wiring Diagram* and generate cabling lists prior to realizing the complete schematic design.

The *Wiring Diagram* lets user define the way in which *Components* will connect to one another and to reserve cables that will be used in forming these connections.

**Note:** It is not compulsory for the *Wiring Diagrams* to be created before scheme design.

**Wiring Diagram Cable Reservation**

In order to reserve cables in a *Wiring Diagram*, it is a requirement that *Symbols* have been placed and have been connected to one another with the *Draw Cable* command. It is then possible to Right Click on a cable connecting components to access the Contextual Menu and *Reserve Cables and Cores*.

![Image of wiring diagram with cable reservation options]

This options access the *Cables and Cores Reservation* dialog where cables can be reserved and then used later in the schematic design development.
Inserting Terminals

Terminals are symbols that have a distinct classification within the library. There are two commands for inserting terminals in schemes one will insert individual, (single), terminals, another that will insert multiple terminals.

Terminals have a mark in the same way as other symbols, but are associated to a terminal strip.

Editing Terminal Strips

The Terminal strips command is available in the Project tab.
The terminal strips are grouped by location. Each terminal strip is associated to a configuration file used when automatically generating terminal drawings. Any terminal strip can be selected and by pressing the Edit button they can be managed.

The Terminal Strips Editor can be used to create wiring terminals, renumber terminals, and manage multi-level terminals.

A terminal strip drawing(s) can be created by pressing the “Generate Drawings” button.
SOLIDWORKS Electrical comes complete with a number of standard reports including:

- Drawing list
- BOM
- Cables
- Connections

The templates used for reports are configurable, so that the amount of information and position within the report can be easily changed.

**Editing a Template**

The reports can be accessed from the “Reports” button on the Project tab.

By selecting any of the reports in the Report Manager, selecting the “Properties” button will open the Report Configuration Edition dialogue.
Generating Reports

Reports can be generated in four different formats:

- Drawing Sheets
- Excel (XLS)
- Text (TXT)
- Extensible Markup Language (XML)

These formats can be created by selecting the appropriate icon in the Report Manager.
Cabinet Layouts

There are two types of cabinet layouts in SOLIDWORKS Electrical:

- 2D cabinet layout created and managed with SOLIDWORKS Electrical
- 3D cabinet layout created and managed with SOLIDWORKS Electrical 3D

The templates used for reports are configurable, so that the amount of information and position within the report can be easily changed.

2D Cabinet Layouts

SOLIDWORKS Electrical includes the ability to create basic 2D cabinet layouts; this can be done by pressing the “2D Cabinet Layout” button on the Process tab.

On opening a Cabinet Layout Drawing the side panel automatically displays a list of the materials available for insertion. This list is populated from the information in the project.

All the listed items have a checkbox to the left of them. If the checkbox has been checked on it indicates that the item has been inserted into the Cabinet Layout.
Right-click on any item in the *Cabinet Layout* list to access the *Insertion Contextual Menu*.

3D Cabinet Layouts

These can be created by selecting the *Process* tab, “SOLIDWORKS Assembly” icon.

When selected, it is possible to define the location in the project that the drawing will be created. One cabinet layout will be created per project location.
Printing

Project documents can be printed from the Print command located on the Project tab.

Selection of the “Print” button accesses the Print Drawing Manager dialog.

It is also possible to publish project documents directly to PDF. This option is available on the Import/Export tab with the “Export PDF Files” button.