SOLIDWORKS Flow Simulation Options

SOLIDWORKS Flow Simulation includes an options dialogue window that allows for defining default options to use for a new project. Some of the options included are unit settings, result plot settings and the engineering database location. This document will cover how to access the SOLIDWORKS Flow Simulation options dialogue window and discuss the different options settings.

How to Access

The SOLIDWORKS Flow Simulation options dialogue window can be accessed through the SOLIDWORKS Tools pull down menu (Tools -> Flow Simulation -> Tools -> Options).
General Options

Font: Allows you to specify the font type and size used for results information displayed in the graphics area.

User-defined database location: Allows you to specify the folder where the ChemBaseUser2.xml file is located. The ChemBaseUser2.xml file stores all the user-defined data and can be shared among different users.

Directory for external databases: Allows you to specify the folder where the database .xml files are located. These .xml files store the external data and can be shared among different users.

Display mesh: When checked, Flow Simulation allows you to display the mesh in Cut Plots and Surface Plots.

Use CPUs (Default): Allows you to specify the number of processors or processor cores used for calculation of a single project, set as default for the Use CPU(s) option in the Run and Batch Run dialog boxes.

Monitor Layout (Default): Allows you to select the solver monitor layout settings for new projects: Default, Recent (from the last calculated project) or one of the previously saved user-defined layouts.

Automatically show callouts: When checked, Flow Simulation allows you to display the callout in the graphics area when you select the item in the Flow Simulation analysis tree.

Update fluid volume: Select Always to always update the fluid volume without notification. Please note that complex SOLIDWORKS models may take time to update the fluid volume. If Automatic is selected the fluid volume will be updated automatically for simple SOLIDWORKS models only.

Show/Hide wall thickness: Allows to display or hide the Minimum wall thickness value in the Global Mesh settings.
Unit Options

**Default unit system for Wizard:** Allows you to specify the system of units selected by default when you create a new project in the Wizard.

**Unit notation for results display:**
The following options control the use of scientific notation for analysis results representation:

- **Always use scientific notation:** Select Yes to always use the scientific notation for analysis results. Please note that in this case the three following options become unavailable.

- **Use scientific if decimals are displayed as zeroes:** Select this option to use scientific notation when the precision of a value is higher than the displayed precision, i.e. when significant digits are outside the displayed decimal places and, therefore, only zeroes are displayed in the fractional part of the value.

- **Use scientific if absolute value is less than:** All parameters, which absolute values are smaller than the specified number, are displayed using scientific notation.

- **Use scientific if absolute value is greater than:** All parameters, which absolute values are higher than the specified number, are displayed using scientific notation.
IDI Options

![Image of Options dialog box]

- **Check for temperature range**: When checked, Flow Simulation warns you when the solid temperature exceeds the material melting temperature.

- **Check for velocity range**: When checked, Flow Simulation warns you when the maximum Mach number is less than 1.5 for high Mach number gas flow (the High Mach number flow check box is enabled) or maximum Mach number is greater than 3 for steady-state (1 for transient) gas flow considered as low Mach number flows (the High Mach number flow check box is disabled).

- **Check boundary conditions**: When checked, Flow Simulation automatically checks the internal flow boundary conditions specified in **Boundary Conditions**. For instance, this option warns you if the mass flow rate is unbalanced. A mass flow rate imbalance can occur under the following conditions: if you define only Flow openings which have mass flow rates specified that do not balance; if you define only Flow openings with velocity, mass flow rates or volume flow rates specified and they do not balance exactly.
**Color Bar (Default):**
The following options control the default visualization Parameter and display options for a new plot:

- **Parameter:** Specifies a physical parameter displayed in plots by default.
- **Number of levels:** You can specify the default number of divisions into which the specified parameter range is divided. You can specify up to 255 levels (divisions).
- **Palette:** You can select the desired default color palette.
- **Out of range color:** The following options control the default way the values above maximum and below minimum are displayed:
  - **Get from palette:** The colors for the values above maximum and below minimum correspond to the palette colors for the maximum and minimum values.
  - **Custom:** The colors for the values above maximum and below minimum are defined by the user.
  - **Transparent:** The values above maximum and below minimum are shown as transparent.
- **Color above maximum:** You can specify the color, which will be used for coloring values that are higher than the maximum specified for the color bar. This option is available if **Custom** color is selected.
**Color below minimum**: You can specify the color, which will be used for coloring values that are lower than the minimum specified for the color bar. This option is available if **Custom** color is selected.

**Show on palette**: Clear this check box to hide the values above maximum and below minimum in the palette.

**Appearance**: The following options control the default display options of the palette:

- **Set maximum number of values**: Select to confine the maximum number of divisions into which the specified parameter range is divided.
- **Plot names**: Select to show the list of the plots associated with this Color Bar in the underline.
- **Plot Min/Max**: Select to display the minimum and maximum values calculated over the plot area in the list of the plots associated with this Color Bar.

**Palette height**: You can specify the default palette bar height.

**Palette width**: You can specify the default palette bar width.

**Background color**: Select the color of the palette background.

**Background transparency**: Specify the transparency of the palette background.

**Display while dynamic (Default)**: This option controls the default value of the **Display while dynamic** option for those of Flow Simulation features used to visualize the calculation results, for which this option is applicable.

**Interpolate results (Default)**: Turns on/off the interpolation of parameter values within cells during results visualization. When checked (default), Flow Simulation displays parameters distribution so that the calculated values (i.e. values in the mesh cell centers) are interpolated within a cell. Clear this option to turn off the interpolation and therefore accelerate loading/displaying results. In this case parameters distribution will be constant within a cell. This option defines the default parameter visualization upon initial loading of the results and can be changed further for a particular view under the **Options** of the **Cut Plot** and **Surface Plot** dialogs and in the **XY Plot** dialog.

**Use CAD geometry (Default)**: By default, Flow Simulation shows the original model while displaying results. Depending on how exactly the model is resolved by the computational mesh, the geometry on which the calculation is performed may differ slightly from the original model's geometry. Clear this option to see the Flow Simulation-interpreted geometry instead of the model.

**Always disable CAD geometry for Play mode**: Select this option to always use the Flow Simulation-interpreted geometry (i.e. meshed geometry) in context animation.

**Hide geometry when displaying plots in solids**: Select this option to always show the plots located inside the solid bodies.

**Arrow style**: Specifies the method velocity vectors are drawn. Select **Line** to draw vectors as lines, select **3D** to draw vectors as 3D object (vector’s arrow is performed by cylinder and cone) or select **3D Wireframe** to draw vectors as 3D object (vector’s arrow is performed by line and pyramid). Use the 3D style if vectors cannot be seen clear enough due to overlapping them by contour plots.

**Apply lighting (Default)**: Enables **Advanced lighting effects** for the newly created Flow Simulation projects. The lighting properties are acquired from the SOLIDWORKS model's lighting.
**Advanced lighting effects:** Allows you to analyze results using a more realistic shaded view of 3D-Profile Plots and Isosurfaces as well as pipes, arrows and spheres along flow and particles trajectories. The lighting properties are acquired from the SOLIDWORKS model's lighting. To apply lighting and activate the shaded view, click **Tools > Flow Simulation > Results > Display > Lighting** or click **Lighting** on the **Flow Simulation Display** toolbar. Please note that you will see the Advanced lighting effects on the already existing postprocessor features only after rebuilding these features. When Advanced lighting effects are enabled, it takes more CPU time to create the postprocessor features, because additional calculations are needed to apply Advanced lighting effects.

**High quality highlight:** Allows you to use a high quality highlight to indicate the selected plots or trajectories.

**Display boundary layer:** Displays or hides boundary layers while displaying the calculation results. Displaying boundary layer requires more computer resources to visualize. Clearing this option can increase the performance of the results visualization. When deselected, the parameter distribution at the boundary layer is ignored (not resolved by the palette). This option defines the boundary layer visualization upon initial loading of the results and can be changed further for a particular view under the **Options** item of the **Cut Plot** dialog and the **XY Plot** dialog.

**Trajectory image quality:** Allows you to adjust the quality of rendering of 3D pipes, arrows or spheres that are used to visualize flow and particle trajectories. You can change the value of **Trajectory image quality** in the range from 1 to 100, the bigger the value, the higher the quality of the 3D trajectories visualization. The default value is 10. Please note that high values can result in a significant increase in CPU time required to build the trajectories, especially in case when the number of trajectories is also high.
Automatic Goals

- Allows you to associate a type of a condition (boundary condition, fan, heat source or radiative surface) with a goal(s), which will be automatically created with the condition.
- For example, if you specify a pressure opening it makes sense to define a mass flow rate surface goal at this opening.
- To associate a condition with a goal(s), double-click the cell at the right of the condition name and select the goals to be created with this condition.
Mail Settings

You may select **Notify when calculation is finished** at the **Finishing** tab in **Calculation Control Options** and Flow Simulation will send an e-mail message with the general information about calculation to the specified addresses when the solver finishes.

- **Send from**: Defines the content of the "From" field of the message. By default, it contains "Solver Monitor <noreply@solver.monitor>". In some cases you may need to specify your actual e-mail address here.

- **Send to (Default)**: Defines the default list of recipients. The list entries must be separated by semicolons. You can modify this list in the **Send to e-mails** field after you select **Notify when calculation is finished** in **Calculation Control Options**.

- **SMTP server**: Specify the name of the SMTP server (the outgoing mail server). In many cases you may find it in your e-mail account settings. If you are not sure what the server name is, please contact your system administrator.

- **Port**: Specify the number of the SMTP server port for Flow Simulation to connect to. In many cases you may find it in your e-mail account settings. Usually the port number is 25. If you are not sure what the port number is, please contact your system administrator.

- **My server requires authentication**: If your mail server requires a password-protected log-in, select this option and specify your **Account name** and **Password**. If you are not sure whether your server requires authentication or not, please contact your system administrator.
Remote Solver

- **Directory for temporary remote solver files**: Allows you to specify the folder for the remote solver temporary files.
- **Port**: The number of port used by the Remote Solver when you run the calculation on this computer from another computer in the network. The port number must be in the range from 1024 to 65535. The specified port number must not be in use by any other process. If you are not sure that the specified port number is appropriate for your system, please contact your system administrator.